Pages: [1]   Go Down
  Print  
Author Topic: Tech advice needed plz.  (Read 44 times)
headsup
Gold Member
****
Offline Offline

Posts: 2464


WWW

Ignore
« on: March 15, 2019, 12:33:42 AM »

80's LS-2 with 2 EMG pick-ups.
lovely guitar, I didn't play it as much as i should because there is a noticeable "POP" overtime i use the pick-up switch selector.
 I suspect it's related to the active EMG's, I've had EMG's in other guitars before, never had this popping sound...
any ideas from the knowledgable folks around here?



* IMG_0511.jpg (220.74 KB, 1280x960 - viewed 0 times.)
Logged

"Senior" member means "old" right?
Like over 50?

Too many guitars to list here.
 Too few brain cells to be bothered with...
Barefoot Rob
Donuts?
*****
Offline Offline

Posts: 14430




Ignore
« Reply #1 on: March 15, 2019, 02:32:57 AM »

The only "pop" I every had with EMG's is when the battery below 9 volts,if its coming from the toggle check the contact for the pu they may be worn.Also check the nylon inside tip as it also my be worn or out of kilter.Just my best guess with out having it hand.




OK another thought ran thru my mind check the connections for the battery from the pu.

OK nothin else coming thru.
Logged

A REPAIRPERSON,Still Unclrob
OM03PA
Favorite saying
 OB LA DE OB LA DA,LIFE GOES ON---BRA,It is what it is,You just gotta deal it,
One By One The Penguins Steal My Sanity, Keith and Barefoot Rob on youtube
Still unclrob
#19
12 people ignoring me,so cool
www.rpjguitarworks.com
Call PM me I may b
Pages: [1]   Go Up
  Print  
 
Jump to: